Back
Maintenance

Router Upgrade

Completed 10 Dec at 02:00am GMT.

Unifi Control Panel
Completed

Maintenance completed

Posted 10 Dec at 02:00am GMT.
Started

Applying patches to the router to improve performance.

Posted 10 Dec at 01:00am GMT.